We’ve just added a new app to our control panel called “Static/CGI/PHP-5.3”.

This means that you can now choose between PHP-5.2 and PHP-5.3 when you create a PHP app.

The PHP-5.3 command line tools are also installed on all servers:

[remi@web180 ~]$ php53 -v
PHP 5.3.5 (cli) (built: Mar 15 2011 06:04:49)
[...]

[remi@web180 ~]$ php -v
PHP 5.2.11 (cli) (built: Oct 18 2010 14:11:48)
[...]

Enjoy!

PS: Note that the PHP-5.3 app is only available on Web120 and over. This is because machines before that use mod_php to serve PHP apps and Apache can’t run mod_php-5.2 and mod_php-5.3 side by side. If you’re on a machine before that and want to run PHP-5.3 you can either build your own Apache/PHP-5.3 stack or ask for a plan on a newer server. Open a ticket and we’ll be happy to help.

Update May 12th: The PHP-5.3 app is now available on all servers.